Another Dell XPS M1330 tip: External Display Flicker

Although five of us have exact same setup, I am the only one at work to experience the external display flickering. I tried everything from downloading all the latest updates from the dell site, mucking around with all the display options to no avail. I even plugged in my XPS to a couple of my colleagues displays (in high hopes of stealing it if it worked) but no, it had to flicker for my laptop. Whereas they would happy go about their merry day with a crystal clear and crisp display while I looked on enviously.

I finally got fed up today when the flickering worsened and asked Google again, “why me?” and Google replied “You are not alone”, the only problem was that I had to go through Google cache as Dell seems to have pulled the plug on this particular page.

Thankfully Brandon (aka GadgetPhreak) had found a workaround and posted it way back in Dec 07, here’s what he says.

I purchased an XPS M1330 configured as follows:

  • SYSTEM COLOR: Tuxedo Black
  • PROCESSOR: Intel® Core™ 2 Duo Processor T7500 (2.2GHz/800Mhz FSB, 4MB Cache)
  • OPERATING SYSTEM: Genuine Windows Vista™ Business Edition
  • LCD AND CAMERA: Slim and Light LED Display with VGA Webcam
  • MEMORY: 3GB Shared Dual Channel DDR2 at 667MHz
  • HARD DRIVE: Speed: 160GB SATA Hard Drive (7200RPM)
  • INTERNAL OPTICAL DRIVE: CD/DVD burner (DVD+/-RW Drive)
  • VIDEO CARD: 128MB NVIDIA® GeForce™ 8400M GS
  • WIRELESS CARDS: Intel Next-Gen Wireless-N Mini-card
  • BLUETOOTH AND WIRELESS USB: Built-in Bluetooth capability (2.0 EDR)
  • BATTERY OPTIONS: 6 cell Primary Battery and 9 cell additional Lithium Ion Battery
  • SOUND OPTIONS: ExpressCard Sound Blaster X-Fi® Xtreme Audio Sound Card
  • FINGERPRINT SCANNER: Biometric Fingerprint Reader

I attempted to connect it to the same external monitor used with my XPS 1210 (a 20" Viewsonic VX2025wm LCD with a native resolution of 1680×1050) and where I used to get a crisp, clean, flicker-free image with my M1210, I now get a lot of screen flicker.

I did some research and found someone running a similar type of LCD who had better luck with using an HDMI to DVI-D adapter and ran it into the DVI input on his monitor.  However, that didn’t work for me.

In trouble shooting this I found something interesting, when I remove AC power to my laptop while connected to the Viewsonic, the flickering stops.  When I reconnect it the flickering starts up again.  This is true regardless of what resolution I am running on either the laptop or Viewsonic.  I went through the advanced power settings and tried looking for differences for when the AC is plugged in vs. when it’s running on battery.  I also tried re-installing video drivers, as well as the latest Nvidia drivers from Dell downloads.  Nothing has resolved this yet.

Suggestions?

Thanks in advance,

Branden

 

And behold I pulled out my power cable and the flickering stopped! Now I’m off to customer support to see if I can get an HDMI to DVI cable 😉

Another Dell XPS M1330 tip: External Display Flicker